[libcxx-commits] [PATCH] D144915: [libc++] Fix modules issues on OS X

Louis Dionne via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Tue Feb 28 14:52:46 PST 2023


ldionne added a comment.

In D144915#4159110 <https://reviews.llvm.org/D144915#4159110>, @Mordante wrote:

> Mainly curios, but how do curses get pulled into our tests?

I think this is via Apple's SDK, which seem to provide ncurses. This is arguably not very clean.

In D144915#4159182 <https://reviews.llvm.org/D144915#4159182>, @philnik wrote:

> We could rename it to `types` or something similar. It would actually also make sense to put stuff like `MoveOnly`, `input_iterator` etc. inside there. Then we'd have `types::for_each(types::integral_types{}, ...)`. WDYT?

Yeah, I've been wanting a namespace to put our test support utilities. Let's use `types::` for now, however I think `support::` could also be a good candidate if we want to generalize this to also contain functions and so on.

> Could we maybe get a modules build on macOS, since it seems there are some pretty horrible things inside the system headers? Who thought it would be a good idea to reserve `Point`? I think Android has a few horrific things in the system headers too, but there we don't have any CI currently.

That's a good idea, adding one.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D144915/new/

https://reviews.llvm.org/D144915



More information about the libcxx-commits mailing list