[libcxx-commits] [PATCH] D134216: [SystemZ][z/OS] add code for hardware_concurrency()

Zibi Sarbino via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Tue Oct 25 12:53:49 PDT 2022


zibi added inline comments.


================
Comment at: libcxx/src/support/ibm/hardware_concurrency_zos.cpp:37
+unsigned
+thread::hardware_concurrency() noexcept {
+  return ((((int* __ptr32* __ptr32* __ptr32)0)[4])[165])[53];
----------------
Why don't you rename this to `hardware_concurrency_zos() ` , make it static function and call it from the original place in `thread.cpp`?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D134216/new/

https://reviews.llvm.org/D134216



More information about the libcxx-commits mailing list