[libcxx-commits] [PATCH] D122017: [libc++] Rename __identity to __type_identity
Nikolas Klauser via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Fri Mar 18 09:54:57 PDT 2022
philnik created this revision.
philnik added reviewers: ldionne, Mordante.
Herald added a project: All.
philnik requested review of this revision.
Herald added a project: libc++.
Herald added a subscriber: libcxx-commits.
Herald added a reviewer: libc++.
In C++20 the type trait `type_identity` was introduced. For the same purpose there is `__identity` for pre-C++20 code. The name is confusing, because since C++20 there is also `identity`, which isn't a type trait.
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D122017
Files:
libcxx/include/__memory/unique_ptr.h
libcxx/include/deque
libcxx/include/forward_list
libcxx/include/list
libcxx/include/map
libcxx/include/set
libcxx/include/type_traits
libcxx/include/unordered_map
libcxx/include/unordered_set
libcxx/include/variant
libcxx/include/vector
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D122017.416536.patch
Type: text/x-patch
Size: 17307 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/libcxx-commits/attachments/20220318/e937367a/attachment.bin>
More information about the libcxx-commits
mailing list