[libcxx-commits] [PATCH] D129520: [libc++][ranges] implement `std::ranges::set_symmetric_difference`
Nikolas Klauser via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Wed Jul 13 03:59:22 PDT 2022
philnik added inline comments.
================
Comment at: libcxx/include/__algorithm/set_symmetric_difference.h:27-29
+ _InIter1 in1;
+ _InIter2 in2;
+ _OutIter out;
----------------
huixie90 wrote:
> should these names be double underscored? if so, what is the naming convention?
>
> afaik, `__out` is a nasty macro and `__out_iter` clashes with the constructor argument name.
They should be called `__in1_`, `__in2_` and `__out_`.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D129520/new/
https://reviews.llvm.org/D129520
More information about the libcxx-commits
mailing list