[libcxx-commits] [PATCH] D129520: [libc++][ranges] implement `std::ranges::set_symmetric_difference`
Hui via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Wed Jul 13 00:31:53 PDT 2022
huixie90 marked an inline comment as done.
huixie90 added inline comments.
================
Comment at: libcxx/include/__algorithm/set_symmetric_difference.h:27-29
+ _InIter1 in1;
+ _InIter2 in2;
+ _OutIter out;
----------------
should these names be double underscored? if so, what is the naming convention?
afaik, `__out` is a nasty macro and `__out_iter` clashes with the constructor argument name.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D129520/new/
https://reviews.llvm.org/D129520
More information about the libcxx-commits
mailing list