[libcxx-commits] [PATCH] D132293: [libc++] Improves feature-test macro diagnostics.

Mark de Wever via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Tue Aug 30 08:55:56 PDT 2022


Mordante marked an inline comment as done.
Mordante added a comment.

Thanks for the reviews!



================
Comment at: libcxx/utils/generate_feature_test_macro_components.py:985
 #   ifdef {name}
-#     error "{name} should not be defined when {test_suite_guard} is not defined!"
+#     error "{name} should not be defined when the requirement {test_suite_guard} is not met!"
 #   endif
----------------
var-const wrote:
> Optional: do you think surrounding the expanded text with some symbol (e.g. quotes or backticks) will make the resulting string easier to read? E.g. (note the quotes):
> ```
> __cpp_lib_shared_mutex should not be defined when the requirement "!defined(_LIBCPP_HAS_NO_THREADS) && !defined(_LIBCPP_AVAILABILITY_DISABLE_FTM___cpp_lib_shared_mutex)" is not met!
> ```
Good suggestion: I will use the single quote to avoid escapes in the generated message.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D132293/new/

https://reviews.llvm.org/D132293



More information about the libcxx-commits mailing list