[libcxx-commits] [PATCH] D132293: [libc++] Improves feature-test macro diagnostics.

Konstantin Varlamov via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Mon Aug 29 20:02:00 PDT 2022


var-const accepted this revision.
var-const added a comment.

Thanks for addressing this! I think this reads a lot better than the previous version. The double negation is still there, but it looks like it would require disproportional effort to get rid of that, and this looks like a very nice improvement.



================
Comment at: libcxx/utils/generate_feature_test_macro_components.py:985
 #   ifdef {name}
-#     error "{name} should not be defined when {test_suite_guard} is not defined!"
+#     error "{name} should not be defined when the requirement {test_suite_guard} is not met!"
 #   endif
----------------
Optional: do you think surrounding the expanded text with some symbol (e.g. quotes or backticks) will make the resulting string easier to read? E.g. (note the quotes):
```
__cpp_lib_shared_mutex should not be defined when the requirement "!defined(_LIBCPP_HAS_NO_THREADS) && !defined(_LIBCPP_AVAILABILITY_DISABLE_FTM___cpp_lib_shared_mutex)" is not met!
```


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D132293/new/

https://reviews.llvm.org/D132293



More information about the libcxx-commits mailing list