[libcxx-commits] [PATCH] D109435: [libc++][NFC] Rename _EnableIf to __enable_if_t for consistency
Louis Dionne via Phabricator via libcxx-commits
libcxx-commits at lists.llvm.org
Wed Sep 8 12:20:50 PDT 2021
ldionne accepted this revision as: libc++.
ldionne added a comment.
This revision is now accepted and ready to land.
In D109435#2989549 <https://reviews.llvm.org/D109435#2989549>, @Quuxplusone wrote:
> Per my latest comment/update on D109411 <https://reviews.llvm.org/D109411>: I buy this now. We're switching away from the SCARY metabase technique (which irreparably interferes with the good diagnostics) at the same time that we're switching away from the `_EnableIf` name. Simultaneously, on the Clang side, we're special-casing the //new// name, `__enable_if_t`, so that it will start giving the good diagnostics.
>
> (I think it would still be nice to decide whether we are going to use `__enable_if_t` throughout for consistency, or permit `_LIBCPP_STD_VER > 11` codepaths to use `enable_if_t` if they want. I predict the latter will win out anyway, though.)
My opinion is that we should use `enable_if_t` where we can, and `__enable_if_t` when we can't because the std version doesn't permit us to do so. It's what we do for all other utilities, e.g. `std::__to_address` & friends, so that approach seems consistent to me.
> LGTM, ship it! Assuming you agree with D109411 <https://reviews.llvm.org/D109411> at this point too.
Yes, I agree with D109411 <https://reviews.llvm.org/D109411> (just approved it).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D109435/new/
https://reviews.llvm.org/D109435
More information about the libcxx-commits
mailing list