[libcxx-commits] [PATCH] D101242: [libcxx][nfc] renames test iterator types to `legacy_*_iterator`

Christopher Di Bella via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Mon Apr 26 09:59:46 PDT 2021


cjdb added a comment.

In D101242#2715229 <https://reviews.llvm.org/D101242#2715229>, @Mordante wrote:

> I had a short look at the patch. I also wonder whether this is the direction we want to go.

The intention of this patch is to optimise for the reader, not the writer. I don't want any contributors or reviewers to question whether `input_iterator` means legacy input iterator or C++20 input iterator.

> For reviewing, I assume this is all basically a search and replace? Or are there more changes?

Should be a 100% search and replace with one file renamed too (`input_iterator.h` -> `legacy_input_iterator.h`).



================
Comment at: libcxx/test/support/test_iterators.h:1
 //===----------------------------------------------------------------------===//
 //
----------------
Mordante wrote:
> The new C++20 style iterators will they also be put in this file or will they get their own header. If the latter then maybe rename this file to `test_legacy_iterator.h`.
My intention was to add them here and guard them with a ranges support macro. C++20 ranges may want to test both in certain circumstances.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D101242/new/

https://reviews.llvm.org/D101242



More information about the libcxx-commits mailing list