[PATCH] D54726: [libcxx] Support generating linker script for static library

Petr Hosek via Phabricator reviews at reviews.llvm.org
Mon Nov 19 15:46:55 PST 2018


phosek added inline comments.


================
Comment at: libcxx/lib/CMakeLists.txt:392
+    ARGS
+      "${CMAKE_STATIC_LIBRARY_PREFIX}c++static${CMAKE_STATIC_LIBRARY_SUFFIX}"
+      "$<TARGET_LINKER_FILE:cxx_static>"
----------------
ldionne wrote:
> Why call it `libc++static.a` instead of `libc++.a`?
We rename `libc++.a` to `libc++static.a` and then create linker script called `libc++.a` in its place that contains `INPUT(libc++static.a ...)`.  Like I said in my email, I'm not a big fan of that name so I welcome other suggestions.

ChromeOS toolchain already does this in their toolchain build and they use the name `libc++_static.a` (I dropped `_` because we already have `libc++fs.a` and `libc++experimental.a`), libstdc++ uses the same approach and they use the name `libstdc++_nonshared.a`.


Repository:
  rCXX libc++

https://reviews.llvm.org/D54726





More information about the libcxx-commits mailing list