[libc-commits] [PATCH] D132809: [libc][math] Added auxiliary function log2_eval for asinhf/acoshf/atanhf.

Tue Ly via Phabricator via libc-commits libc-commits at lists.llvm.org
Mon Aug 29 14:45:56 PDT 2022


lntue added inline comments.


================
Comment at: libc/src/math/generic/supfuncf.h:9
 
-#ifndef LLVM_LIBC_SRC_MATH_GENERIC_EXPXF_H
-#define LLVM_LIBC_SRC_MATH_GENERIC_EXPXF_H
+#ifndef LLVM_LIBC_SRC_MATH_GENERIC_EXPLOGXF_H
+#define LLVM_LIBC_SRC_MATH_GENERIC_EXPLOGXF_H
----------------
orex wrote:
> lntue wrote:
> > `explogxf.h` is a better name for this file and cmake target.
> Please check also  D132811 I've added to the file also atan_eval function, so therefore it is named such. If you have any other suggestion about the file name I'll appreciate your suggestion.
The constants and `atan_eval` function that you added in https://reviews.llvm.org/D132842 are independent with these `exp` and `log` utilities.  Maybe you can put them into separate files / target called `inv_trig_utils` or `inv_trig_helpers`, as I expect `asin` and `acos` will also need some helpers, which could be put in there.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D132809/new/

https://reviews.llvm.org/D132809



More information about the libc-commits mailing list