[libc-commits] [PATCH] D75487: [libc] [UnitTest] Add Matchers

Alex Brachet via Phabricator via libc-commits libc-commits at lists.llvm.org
Wed Mar 4 21:45:19 PST 2020


abrachet updated this revision to Diff 248390.
abrachet added a comment.

- Rename Matchers.h to ErrnoSetterMatcher.h
- Moved `Fails` and `Succeeds` behind `namespace ErrnoSetterMatcher` so they can be easily shorted with `using`
- Removed some newlines between `EXPECT_THAT`'s in sigaddset_test.cpp
- Put ErrnoSetterMatcher in `namespace __llvm_libc::testing`


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D75487/new/

https://reviews.llvm.org/D75487

Files:
  libc/test/src/signal/sigaddset_test.cpp
  libc/utils/UnitTest/CMakeLists.txt
  libc/utils/UnitTest/ErrnoSetterMatcher.h
  libc/utils/UnitTest/Test.cpp
  libc/utils/UnitTest/Test.h
  libc/utils/testutils/CMakeLists.txt
  libc/utils/testutils/StreamWrapper.cpp
  libc/utils/testutils/StreamWrapper.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D75487.248390.patch
Type: text/x-patch
Size: 11526 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/libc-commits/attachments/20200305/a8f6575d/attachment.bin>


More information about the libc-commits mailing list