[PATCH] D151730: [RISCV] Support target attribute for function

Philip Reames via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Jul 7 10:29:55 PDT 2023


reames added a comment.

Can you separate the change to RISCVAsmPrinter.cpp into it's own review?  This looks useful for any case where we have functions in the same model with different function attributes.  The __attribute__((target...) syntax is one way to have that, but there are also others.  LTO will see this, and so may other frontends.

This will also help with review as the set of people who can review RISCV backend changes and clang frontend changes is fairly non-overlapping.



================
Comment at: llvm/test/CodeGen/RISCV/riscv-func-attr-target.ll:5
+; CHECK-NEXT: .option        arch,   +c, +v, +zifencei, +zve32f, +zve32x, +zve64d, +zve64f, +zve64x, +zvl128b, +zvl32b, +zvl64b
+define void @test1() #0 {
+; CHECK-LABEL: test1
----------------
This test would be a lot easier to follow if you pruned all the spurious attributes, and uses the inline attribute syntax rather than the #0 reference syntax.  


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D151730/new/

https://reviews.llvm.org/D151730



More information about the cfe-commits mailing list