[PATCH] D151581: [clang][modules] NFCI: Distinguish written/effective umbrella directories

Ben Langmuir via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri May 26 14:08:10 PDT 2023


benlangmuir accepted this revision.
benlangmuir added inline comments.
This revision is now accepted and ready to land.


================
Comment at: clang/include/clang/Basic/Module.h:655
+  /// Retrieve the explicitly written umbrella directory for this module.
+  DirectoryName getWrittenUmbrellaDir() const {
+    if (const auto *ME = Umbrella.dyn_cast<const DirectoryEntry *>())
----------------
Nit: I would prefer we use the same `...AsWritten` naming scheme for these methods that we use for the `UmbrellaAsWritten` field.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D151581/new/

https://reviews.llvm.org/D151581



More information about the cfe-commits mailing list