[PATCH] D147218: [OpenMP][Flang][MLIR] Lowering of OpenMP requires directive from parse tree to MLIR

Akash Banerjee via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri May 26 05:16:31 PDT 2023


TIFitis added inline comments.


================
Comment at: flang/lib/Lower/OpenMP.cpp:2552
+
+void handleDeclareTarget(Fortran::lower::AbstractConverter &converter,
+                         Fortran::lower::pft::Evaluation &eval,
----------------
This seems to be the only function name with the 'handle' prefix. Maybe rename it to something like `genDeclareTarget` ?


================
Comment at: flang/lib/Lower/OpenMP.cpp:2563
+
+  auto mod = converter.getFirOpBuilder().getModule();
   for (auto sym : symbolAndClause) {
----------------
Remove use of auto here.

Also in other places if the type isn't immediately discernible then consider naming the type. 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D147218/new/

https://reviews.llvm.org/D147218



More information about the cfe-commits mailing list