[PATCH] D148314: [clang-tidy] Improved hungarian notation regression test at post-commit review

Douglas Chen via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Apr 14 02:01:29 PDT 2023


dougpuob created this revision.
Herald added subscribers: carlosgalvezp, xazax.hun.
Herald added a project: All.
dougpuob requested review of this revision.
Herald added a project: clang-tools-extra.
Herald added a subscriber: cfe-commits.

Improve the (`D144510`)[https://reviews.llvm.org/D144510] patch with prefix string. Using "my" instead of "cust" would increase 
readability.

Take some examples:

- const char* `custszNamePtr` = "Name"; --> `myszNamePtr`
- uint8_t `custu8ValueU8` = 0; --> `myu8ValueU8`
- DWORD `custdwMsDword` = 0; --> `mydwMsDword`


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D148314

Files:
  clang-tools-extra/docs/ReleaseNotes.rst


Index: clang-tools-extra/docs/ReleaseNotes.rst
===================================================================
--- clang-tools-extra/docs/ReleaseNotes.rst
+++ clang-tools-extra/docs/ReleaseNotes.rst
@@ -261,6 +261,11 @@
   <clang-tidy/checks/readability/identifier-naming>` which failed to indicate
   the number of asterisks.
 
+- Improved readability for hungarian notation in
+  :doc:`readability-identifier-naming
+  <clang-tidy/checks/readability/identifier-naming>` by changing the prefix
+  from `cust` to `my` in regression test.
+
 - Fixed a false positive in :doc:`readability-implicit-bool-conversion
   <clang-tidy/checks/readability/implicit-bool-conversion>` check warning would
   be unnecessarily emitted for explicit cast using direct list initialization.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: D148314.513492.patch
Type: text/x-patch
Size: 777 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20230414/5e7ff055/attachment-0001.bin>


More information about the cfe-commits mailing list