[PATCH] D141391: [NFC] [clang-tools-extra] Alphabetize clang-tidy release notes

Chris Cotter via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Jan 10 08:16:13 PST 2023


ccotter updated this revision to Diff 487813.
ccotter added a comment.

- merge from upstream


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D141391/new/

https://reviews.llvm.org/D141391

Files:
  clang-tools-extra/docs/ReleaseNotes.rst


Index: clang-tools-extra/docs/ReleaseNotes.rst
===================================================================
--- clang-tools-extra/docs/ReleaseNotes.rst
+++ clang-tools-extra/docs/ReleaseNotes.rst
@@ -167,6 +167,16 @@
   <clang-tidy/checks/google/objc-avoid-throwing-exception>` check for exceptions
   thrown by code emitted from macros in system headers.
 
+- Improved :doc:`misc-redundant-expression <clang-tidy/checks/misc/redundant-expression>`
+  check.
+
+  The check now skips concept definitions since redundant expressions still make sense
+  inside them.
+
+- Improved :doc:`modernize-loop-convert <clang-tidy/checks/modernize/loop-convert>`
+  to check for container functions ``begin``/``end`` etc on base classes of the container
+  type, instead of only as direct members of the container type itself.
+
 - Improved :doc:`modernize-use-emplace <clang-tidy/checks/modernize/use-emplace>`
   check.
 
@@ -206,20 +216,10 @@
   <clang-tidy/checks/readability/const-return-type>` to not
   warn about `const` value parameters of declarations inside macros.
 
-- Improved :doc:`misc-redundant-expression <clang-tidy/checks/misc/redundant-expression>`
-  check.
-
-  The check now skips concept definitions since redundant expressions still make sense
-  inside them.
-
 - Support removing ``c_str`` calls from ``std::string_view`` constructor calls in
-  :doc: `readability-redundant-string-cstr <clang-tidy/checks/readability/redundant-string-cstr>`
+  :doc:`readability-redundant-string-cstr <clang-tidy/checks/readability/redundant-string-cstr>`
   check.
 
-- Improved :doc:`modernize-loop-convert <clang-tidy/checks/modernize/loop-convert>`
-  to check for container functions ``begin``/``end`` etc on base classes of the container
-  type, instead of only as direct members of the container type itself.
-
 Removed checks
 ^^^^^^^^^^^^^^
 


-------------- next part --------------
A non-text attachment was scrubbed...
Name: D141391.487813.patch
Type: text/x-patch
Size: 1861 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20230110/c369e78f/attachment-0001.bin>


More information about the cfe-commits mailing list