[PATCH] D139115: [clang][ExtractAPI] Add support for single symbol SGF
Ben Langmuir via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Dec 9 16:46:28 PST 2022
benlangmuir added a comment.
Thanks, the libclang change LGTM other than my comment about the function names.
================
Comment at: clang/include/clang-c/Documentation.h:589
+ */
+CINDEX_LINKAGE CXString clang_getSingleSymbolSymbolGraphForUSR(const char *usr,
+ CXAPISet api);
----------------
`clang_getSingleSymbolSymbolGraphForUSR` is a bit hard to read with the double "symbol". What do you think of
* `clang_getSymbolGraphForUSR`
* `clang_getSymbolGraphForCursor`
Or perhaps `clang_getSymbolGraphFragmentFor...`? My thinking is that both USR and Cursor are already implying it is a single symbol so we can avoid the "single-symbol symbol-graph" term.
I'm not deeply familiar with this API, so apologies if this suggestion makes no sense 😅
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D139115/new/
https://reviews.llvm.org/D139115
More information about the cfe-commits
mailing list