[PATCH] D136854: [HIP] add -fhiplib-add-rpath

Yaxun Liu via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Thu Oct 27 10:54:11 PDT 2022


yaxunl added a comment.

In D136854#3889141 <https://reviews.llvm.org/D136854#3889141>, @MaskRay wrote:

> If an option does not affect compilation, I prefer `--` to `-f`

I will rename it as --offload-add-rpath



================
Comment at: clang/include/clang/Driver/Options.td:4158
+  HelpText<"Add -rpath with HIP runtime library directory to the linker flags">;
+def fno_hiplib_add_rpath: Flag<["-"], "fno-hiplib-add-rpath">, Flags<[NoArgumentUnused]>,
+  HelpText<"Do not add -rpath with HIP runtime library directory to the linker flags">;
----------------
tra wrote:
> Any reason not to use `BoolFOption` instead of defining `-fno...` option separately?
BoolFOption seems to be associated with LangOpts or CodeGenOpts, but this one only affects the options passed to linker and does not have corresponding LangOpts or CodeGenOpts. This is similar to -frtlib-add-rpath.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D136854/new/

https://reviews.llvm.org/D136854



More information about the cfe-commits mailing list