[PATCH] D135384: [AIX] Enable the use of the -pg flag

Hubert Tong via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Oct 11 22:10:54 PDT 2022


hubert.reinterpretcast added inline comments.


================
Comment at: llvm/lib/Transforms/Utils/EntryExitInstrumenter.cpp:38-40
+    const Twine targetTwine(M.getTargetTriple());
+    Triple targetTriple(targetTwine);
+    if (targetTriple.isOSAIX()) {
----------------
A `Twine` can be implicitly constructed from a `std::string`. The implicit conversion works in this context.
Also: Change the variable name to use the LLVM naming convention for non-"functions".


================
Comment at: llvm/lib/Transforms/Utils/EntryExitInstrumenter.cpp:40
+    Triple targetTriple(targetTwine);
+    if (targetTriple.isOSAIX()) {
+      Type *SizeTy = M.getDataLayout().getIntPtrType(C);
----------------
I see no reason why we should assume that all of the other function names should have the extra argument passed on AIX.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D135384/new/

https://reviews.llvm.org/D135384



More information about the cfe-commits mailing list