[PATCH] D135489: [clangd] Fix rename for symbol introduced by UsingDecl
Tom Praschan via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Oct 7 14:31:53 PDT 2022
tom-anders added inline comments.
================
Comment at: clang-tools-extra/clangd/refactor/Rename.cpp:169
+// For renaming, we're only interested in foo's declaration, so drop the other one
+void filterBaseUsingDecl(llvm::DenseSet<const NamedDecl *>& Decls) {
+ if (Decls.size() == 2) {
----------------
I'm not really happy with the name here, open for suggestions
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D135489/new/
https://reviews.llvm.org/D135489
More information about the cfe-commits
mailing list