[clang] 5ed25e4 - [CUDA][NFC] Rename 'addDeviceDepences' to 'addDeviceDependences' in DeviceActionBuilder.
via cfe-commits
cfe-commits at lists.llvm.org
Sun Sep 18 19:43:29 PDT 2022
Author: wanglian
Date: 2022-09-19T10:43:09+08:00
New Revision: 5ed25e4df6a705d63b4e81c274f8385a0a1188f9
URL: https://github.com/llvm/llvm-project/commit/5ed25e4df6a705d63b4e81c274f8385a0a1188f9
DIFF: https://github.com/llvm/llvm-project/commit/5ed25e4df6a705d63b4e81c274f8385a0a1188f9.diff
LOG: [CUDA][NFC] Rename 'addDeviceDepences' to 'addDeviceDependences' in DeviceActionBuilder.
Reviewed By: tra
Differential Revision: https://reviews.llvm.org/D134007
Added:
Modified:
clang/lib/Driver/Driver.cpp
Removed:
################################################################################
diff --git a/clang/lib/Driver/Driver.cpp b/clang/lib/Driver/Driver.cpp
index d8b13730f588..a67cf3615244 100644
--- a/clang/lib/Driver/Driver.cpp
+++ b/clang/lib/Driver/Driver.cpp
@@ -2736,7 +2736,7 @@ class OffloadingActionBuilder final {
/// Update the state to include the provided host action \a HostAction as a
/// dependency of the current device action. By default it is inactive.
- virtual ActionBuilderReturnCode addDeviceDepences(Action *HostAction) {
+ virtual ActionBuilderReturnCode addDeviceDependences(Action *HostAction) {
return ABRT_Inactive;
}
@@ -2824,7 +2824,7 @@ class OffloadingActionBuilder final {
Action::OffloadKind OFKind)
: DeviceActionBuilder(C, Args, Inputs, OFKind) {}
- ActionBuilderReturnCode addDeviceDepences(Action *HostAction) override {
+ ActionBuilderReturnCode addDeviceDependences(Action *HostAction) override {
// While generating code for CUDA, we only depend on the host input action
// to trigger the creation of all the CUDA device actions.
@@ -3603,7 +3603,7 @@ class OffloadingActionBuilder final {
if (!SB->isValid())
continue;
- auto RetCode = SB->addDeviceDepences(HostAction);
+ auto RetCode = SB->addDeviceDependences(HostAction);
// Host dependences for device actions are not compatible with that same
// action being ignored.
More information about the cfe-commits
mailing list