[PATCH] D133920: [X86][fastcall] Move capability check before free register update

Reid Kleckner via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Thu Sep 15 11:47:50 PDT 2022


rnk added inline comments.


================
Comment at: clang/lib/CodeGen/TargetInfo.cpp:1781
+
+      return (Ty->isIntegralOrEnumerationType() || Ty->isPointerType() ||
+              Ty->isReferenceType());
----------------
I think we could improve readability here with some named variable booleans and by avoiding the lambda. These come to mind:
  bool IsPtrOrInt =
  bool CCUsesInReg = ...

  


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D133920/new/

https://reviews.llvm.org/D133920



More information about the cfe-commits mailing list