[PATCH] D111509: [clang] use getCommonSugar in an assortment of places
David Rector via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Tue Sep 13 08:02:17 PDT 2022
davrec added inline comments.
================
Comment at: clang/lib/Sema/SemaExpr.cpp:1113-1114
+// "double _Complex" is promoted to "long double _Complex".
+static QualType handleComplexFloatConversion(Sema &S, ExprResult &LHS,
+ QualType LHSType, QualType RHSType,
+ bool PromotePrecision) {
----------------
davrec wrote:
> Rename params for clarity, e.g.
> LHS->Longer
> LHSType->LongerType
> RHSType->ShorterType
>
Actually I probably have that backwards, I think LHS is the Shorter expression...in any case you see why renaming would be helpful
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D111509/new/
https://reviews.llvm.org/D111509
More information about the cfe-commits
mailing list