[PATCH] D126845: [clang-format] Handle Verilog numbers and operators
MyDeveloperDay via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Mon Jun 6 02:02:48 PDT 2022
MyDeveloperDay added inline comments.
================
Comment at: clang/lib/Format/FormatToken.h:1417
// Workaround for hashes and backticks in Verilog.
IdentifierInfo *verilogHash;
IdentifierInfo *verilogHashHash;
----------------
maybe `kw_verilogHash` and `kw_verilogHashHash` and `kw_quote` for clarity when using isOneOf
================
Comment at: clang/lib/Format/FormatToken.h:1421
+ // Symbols in Verilog that don't exist in C++.
+ IdentifierInfo *quote;
+
----------------
HazardyKnusperkeks wrote:
> apostrophe
kw_apostrophe?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D126845/new/
https://reviews.llvm.org/D126845
More information about the cfe-commits
mailing list