[PATCH] D125954: [analyzer][NFC] Factor out the copy-paste code repetition of assumeDual and assumeInclusiveRangeDual
Balázs Benics via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Thu May 19 08:02:03 PDT 2022
steakhal accepted this revision.
steakhal added a comment.
This revision is now accepted and ready to land.
Okay, it still looks a bit odd, but this is definitely an increment.
================
Comment at: clang/lib/StaticAnalyzer/Core/ConstraintManager.cpp:48
+ConstraintManager::assumeDualImpl(ProgramStateRef &State,
+ AssumeFunction &Assume) {
+ ProgramStateRef StTrue = Assume(true);
----------------
Although this is a variable referring to a function, it's still a variable.
I find it difficult to read if a variable name is a //verb//.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D125954/new/
https://reviews.llvm.org/D125954
More information about the cfe-commits
mailing list