[PATCH] D125706: [analyzer][NFC] Use idiomatic classof instead of isKind
Balázs Benics via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Mon May 16 10:35:07 PDT 2022
steakhal created this revision.
steakhal added reviewers: NoQ, martong, Szelethus, balazske, ASDenysPetrov, bzcheeseman.
Herald added subscribers: manas, dkrupp, donat.nagy, mikhail.ramalho, a.sidorin, rnkovacs, szepet, baloghadamsoftware, xazax.hun.
Herald added a project: All.
steakhal requested review of this revision.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.
- Rename `isKind()` to `classof()` to follow the llvm style RTTI.
- Take SVal by-value instead of reference.
- Mark `classof` public.
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D125706
Files:
clang/include/clang/StaticAnalyzer/Core/PathSensitive/SVals.h
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D125706.429767.patch
Type: text/x-patch
Size: 9470 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20220516/0c997dc9/attachment.bin>
More information about the cfe-commits
mailing list