[PATCH] D124774: [clang][ASTImporter][NFC]: Move clang::ImportError into own header and rename it .
Shivam Rajput via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed May 4 00:48:35 PDT 2022
phyBrackets added inline comments.
================
Comment at: clang/include/clang/AST/ASTImportError.h:22
+
+class ImportError : public llvm::ErrorInfo<ImportError> {
+public:
----------------
balazske wrote:
> balazske wrote:
> > Rename to `ASTImportError`.
> The rename to `ASTImportError` is better in a separate patch. The rename would touch code in much more places and there is a rule to make independent changes in separate patches. Still I think this class should not be called just `ImportError` if it has an own header (it is not an internal-like class of `ASTImporter` as is used to be).
So, what do you suggest , for this patch should I go with name //ImportError// only ? And rename it as //ASTImportError// in a separate patch ?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D124774/new/
https://reviews.llvm.org/D124774
More information about the cfe-commits
mailing list