[PATCH] D115967: [clang-format][NFC] Handle wrapping after => in mustBreakBefore()

Owen Pan via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Sun Dec 19 23:12:49 PST 2021


owenpan updated this revision to Diff 395380.
owenpan added a comment.

Additional cleanups:

- Restrict parsing `=>` to JavaScript and C#.
- Rename `tryToParseCSharpLambda` to `tryToParseChildBlock`.
- Remove redundant caret `case`.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D115967/new/

https://reviews.llvm.org/D115967

Files:
  clang/lib/Format/TokenAnnotator.cpp
  clang/lib/Format/UnwrappedLineParser.cpp
  clang/lib/Format/UnwrappedLineParser.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D115967.395380.patch
Type: text/x-patch
Size: 5217 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20211220/134cd9f6/attachment-0001.bin>


More information about the cfe-commits mailing list