[PATCH] D113489: [AArch64][SVE] Instcombine SVE LD1/ST1 to stock LLVM IR

Paul Walker via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Nov 15 04:22:49 PST 2021


paulwalker-arm accepted this revision.
paulwalker-arm added a comment.
This revision is now accepted and ready to land.

There's an issue with the a `Value*` being named `VecPtrTy` but otherwise this looks good to me.

I'll leave it up to you to decide whether it's worth breaking out the usage of update_cc_test_checks.py into a separate patch.  Normally this is a good thing but given the patch is ready to go and I imagine you wouldn't submit the "use update_cc_test_checks.py" patch for review I'm not sure it's worth the effort.



================
Comment at: llvm/lib/Target/AArch64/AArch64TargetTransformInfo.cpp:736
+  Type *VecTy = II.getType();
+  Value *VecPtrTy = Builder.CreateBitCast(PtrOp, VecTy->getPointerTo());
+
----------------
The name here is wrong as this is not a type.  My guess is you meant `VecPtr`?


================
Comment at: llvm/lib/Target/AArch64/AArch64TargetTransformInfo.cpp:758
+  Value *PtrOp = II.getOperand(2);
+  Value *VecPtrTy =
+      Builder.CreateBitCast(PtrOp, VecOp->getType()->getPointerTo());
----------------
As above, I suspect this name is not what you intended.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D113489/new/

https://reviews.llvm.org/D113489



More information about the cfe-commits mailing list