[PATCH] D112889: [analyzer] Dump checker name if multiple checkers evaluate the same call
Balázs Benics via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Tue Nov 2 06:43:11 PDT 2021
steakhal added a comment.
Committed with the requested changes.
================
Comment at: clang/lib/StaticAnalyzer/Core/CheckerManager.cpp:679
+#ifndef NDEBUG
+ if (evaluated && evaluatorChecker.hasValue()) {
+ const auto dump = [](const CallEvent &Call) -> std::string {
----------------
martong wrote:
> Optional implicitly converts to `bool` and IMHO this way it is easier to read the code.
I guess it's up to personal taste.
I'm okay either way, but I more frequently stick to the explicit way of checking this.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D112889/new/
https://reviews.llvm.org/D112889
More information about the cfe-commits
mailing list