[PATCH] D112732: [ASan] Removed AddressSanitizerPass function pass class and rolled it into the module pass for the new pass mangager only.
Vitaly Buka via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Thu Oct 28 11:25:35 PDT 2021
vitalybuka added a comment.
In D112732#3094158 <https://reviews.llvm.org/D112732#3094158>, @kstoimenov wrote:
> Tests are not passing. Hold off the review.
Yep, removed FUNCTION_PASS_WITH_PARAMS("asan", must affect some tests
================
Comment at: llvm/include/llvm/Transforms/Instrumentation/AddressSanitizer.h:113
-/// surrounding requested memory to be checked for invalid accesses.
-class AddressSanitizerPass : public PassInfoMixin<AddressSanitizerPass> {
-public:
----------------
please run check-all
it was used in as well llvm-project/llvm/tools/opt/NewPMDriver.cpp
================
Comment at: llvm/lib/Passes/PassRegistry.def:396
"no-upperbound;upperbound")
-FUNCTION_PASS_WITH_PARAMS("asan",
- "AddressSanitizerPass",
----------------
you should also rename MODULE_PASS_WITH_PARAMS("asan-module", to just MODULE_PASS_WITH_PARAMS("asan",
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D112732/new/
https://reviews.llvm.org/D112732
More information about the cfe-commits
mailing list