[PATCH] D111805: [Driver][NetBSD] Use T reference instead of getToolChain().getTriple().
Frederic Cambus via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Oct 15 01:47:52 PDT 2021
fcambus marked an inline comment as done.
fcambus added inline comments.
================
Comment at: clang/lib/Driver/ToolChains/NetBSD.cpp:35
const Driver &D = ToolChain.getDriver();
+ const llvm::Triple &T = ToolChain.getTriple();
----------------
mgorny wrote:
> Is there a specific reason to choose the name `T`? FWICS different drivers use different names but I think `Triple` is both more popular and more readable.
No specific reason, I agree using the `Triple` name is a better choice. I updated the diff.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D111805/new/
https://reviews.llvm.org/D111805
More information about the cfe-commits
mailing list