[PATCH] D111805: [Driver][NetBSD] Use T reference instead of getToolChain().getTriple().

Michał Górny via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Thu Oct 14 09:06:07 PDT 2021


mgorny added inline comments.


================
Comment at: clang/lib/Driver/ToolChains/NetBSD.cpp:35
   const Driver &D = ToolChain.getDriver();
+  const llvm::Triple &T = ToolChain.getTriple();
 
----------------
Is there a specific reason to choose the name `T`? FWICS different drivers use different names but I think `Triple` is both more popular and more readable.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D111805/new/

https://reviews.llvm.org/D111805



More information about the cfe-commits mailing list