[PATCH] D111588: [Clang][Attr] rename btf_tag to btf_decl_tag

Yonghong Song via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Oct 11 17:20:44 PDT 2021


yonghong-song created this revision.
yonghong-song added reviewers: aaron.ballman, ast, anakryiko.
Herald added a subscriber: jdoerfert.
yonghong-song requested review of this revision.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.

Current btf_tag is applied to declaration only.
Per discussion in https://reviews.llvm.org/D111199,
we plan to introduce btf_type_tag attribute for types.
So rename btf_tag to btf_decl_tag to make it easily
differentiable from btf_type_tag.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D111588

Files:
  clang/include/clang/Basic/Attr.td
  clang/include/clang/Basic/AttrDocs.td
  clang/include/clang/Sema/Sema.h
  clang/lib/CodeGen/CGDebugInfo.cpp
  clang/lib/CodeGen/CGDebugInfo.h
  clang/lib/Sema/SemaDecl.cpp
  clang/lib/Sema/SemaDeclAttr.cpp
  clang/test/CodeGen/attr-btf_tag-dicomposite-2.c
  clang/test/CodeGen/attr-btf_tag-dicomposite.c
  clang/test/CodeGen/attr-btf_tag-diglobalvariable.c
  clang/test/CodeGen/attr-btf_tag-disubprogram-callsite.c
  clang/test/CodeGen/attr-btf_tag-disubprogram.c
  clang/test/CodeGen/attr-btf_tag-field.c
  clang/test/CodeGen/attr-btf_tag-parameter.c
  clang/test/Misc/pragma-attribute-supported-attributes-list.test
  clang/test/Sema/attr-btf_tag.c

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D111588.378833.patch
Type: text/x-patch
Size: 21397 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20211012/02e4a410/attachment-0001.bin>


More information about the cfe-commits mailing list