[PATCH] D110549: [HIPSPV][1/4] Refactor HIP tool chain

Henry Linjamäki via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Sep 28 01:29:50 PDT 2021


linjamaki created this revision.
Herald added subscribers: yaxunl, mgorny.
linjamaki edited the summary of this revision.
linjamaki updated this revision to Diff 375488.
linjamaki added a comment.
linjamaki edited the summary of this revision.
linjamaki added a reviewer: yaxunl.
linjamaki published this revision for review.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.

Style fixes.


This patch refactors the HIP tool chain for new HIP tool chain, HIPSPV
tool chain, which is added in the follow up patch part 2.

- Rename HIPToolChain to HIPAMDToolChain and Renames HIP.* files to HIPAMD.*.

- Introduce HIPUtility.* file where common HIP utilities, shared among HIP tool chain implementations, are placed in.

- Move constructHIPFatbinCommand() and constructGenerateObjFileFromHIPFatBinary() to HIPUtility. HIPSPV tool chain is going to use them.

- Tweak bundle target ID in constructHIPFatbinCommand(): extra dashes are dropped if the Target ID is empty and 'hip' offload kind is made default for non-AMD targets.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D110549

Files:
  clang/lib/Driver/CMakeLists.txt
  clang/lib/Driver/Driver.cpp
  clang/lib/Driver/ToolChains/Clang.cpp
  clang/lib/Driver/ToolChains/CommonArgs.cpp
  clang/lib/Driver/ToolChains/HIP.cpp
  clang/lib/Driver/ToolChains/HIP.h
  clang/lib/Driver/ToolChains/HIPAMD.cpp
  clang/lib/Driver/ToolChains/HIPAMD.h
  clang/lib/Driver/ToolChains/HIPUtility.cpp
  clang/lib/Driver/ToolChains/HIPUtility.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D110549.375488.patch
Type: text/x-patch
Size: 28289 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20210928/80acc309/attachment-0001.bin>


More information about the cfe-commits mailing list