[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check
Saleem Abdulrasool via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Mon Sep 13 09:58:45 PDT 2021
compnerd marked 7 inline comments as done.
compnerd added inline comments.
================
Comment at: clang-tools-extra/clang-tidy/readability/ContainerDataPointerCheck.cpp:63
+ hasType(Container),
+ hasType(pointsTo(Container)),
+ hasType(references(Container))))))
----------------
aaron.ballman wrote:
> Same question here about `pointsTo()`.
This is actually meant to catch cases such as references to UnOp(DRE).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108893/new/
https://reviews.llvm.org/D108893
More information about the cfe-commits
mailing list