[PATCH] D108013: [NFC] Rename AttributeList::has/getAttribute() -> has/getAttributeImpl()
Reid Kleckner via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Aug 13 09:30:07 PDT 2021
rnk added a comment.
There's a related change here: https://reviews.llvm.org/D105485
Honestly, I like this approach better. Adding a strongly-typed integer wrapper is a pretty heavyweight solution for a problem that seems solvable with better named methods.
As a practical matter, consider splitting this up to reduce churn in case anything gets reverted. Most of the `getAttribute` -> `getParamAttr` calls can be migrated ahead of time as NFC commits to improve readability. The most risk-averse version of this change is to leave behind the `getAttribute` entry points as aliases to `getAttributeImpl`, and then remove them in a final commit.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D108013/new/
https://reviews.llvm.org/D108013
More information about the cfe-commits
mailing list