[PATCH] D105981: [AMDGPU][OpenMP] Support linking of math libraries

Pushpinder Singh via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Jul 27 03:51:24 PDT 2021


pdhaliwal added inline comments.


================
Comment at: clang/lib/Driver/ToolChains/AMDGPU.cpp:923-924
+  bool CorrectSqrt = DriverArgs.hasFlag(
+      options::OPT_fhip_fp32_correctly_rounded_divide_sqrt,
+      options::OPT_fno_hip_fp32_correctly_rounded_divide_sqrt);
+  bool Wave64 = isWave64(DriverArgs, Kind);
----------------
I wanted to rename these to something generic like -fgpu-fp32.... but due to some weird reason aliasing wasn't working. Anyhow, my suggestion is to make that change in separate patch.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D105981/new/

https://reviews.llvm.org/D105981



More information about the cfe-commits mailing list