[PATCH] D100733: [clang] NFC: change uses of `Expr->getValueKind` into `is?Value`
Matheus Izvekov via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri May 14 17:27:35 PDT 2021
mizvekov added a comment.
In D100733#2761031 <https://reviews.llvm.org/D100733#2761031>, @rsmith wrote:
> What do we think about renaming `isRValue()` to `isPRValue()` and renaming `VK_RValue` to `VK_PRValue`, adding a "real" `isRValue()`, and then performing this cleanup? I think the current state of treating "rvalue" as sometimes meaning rvalue and sometimes meaning "prvalue" is unhelpful and confusing, and this change makes it worse because `isRValue` *could* be checking for an rvalue whereas a comparison against `VK_RValue` more clearly is only looking for one specific value category rather than two.
Sounds good. For some reason I thought this would be more controversial...
Is there any special reason we ended up in this state of affairs with the swapped out names?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D100733/new/
https://reviews.llvm.org/D100733
More information about the cfe-commits
mailing list