[PATCH] D101491: [ASan] Rename `-fsanitize-address-destructor-kind=` to drop the `-kind` suffix.

Dan Liew via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Apr 28 14:32:28 PDT 2021


delcypher created this revision.
delcypher added reviewers: vitalybuka, jansvoboda11.
Herald added a subscriber: dang.
delcypher requested review of this revision.
Herald added a project: clang.

Renaming the option is based on discussions in https://reviews.llvm.org/D101122.

It is normally not a good idea to rename driver flags but this flag is
new enough and obscure enough that it is very unlikely to have adopters.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D101491

Files:
  clang/docs/ClangCommandLineReference.rst
  clang/include/clang/Driver/Options.td
  clang/lib/Driver/SanitizerArgs.cpp
  clang/test/CodeGen/asan-destructor-kind.cpp
  clang/test/Driver/darwin-asan-mkernel-kext.c
  clang/test/Driver/fsanitize-address-destructor-kind.c
  clang/test/Driver/fsanitize-address-destructor.c

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D101491.341320.patch
Type: text/x-patch
Size: 6736 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20210428/0d76d213/attachment.bin>


More information about the cfe-commits mailing list