[PATCH] D98856: Always emit error for wrong interfaces to scalable vectors, unless cmdline flag is passed.

Christopher Tetreault via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Mar 30 16:05:11 PDT 2021


ctetreau accepted this revision.
ctetreau added inline comments.


================
Comment at: llvm/lib/CodeGen/ValueTypes.cpp:17
 
+unsigned EVT::getVectorNumElements() const {
+  auto Error = []() {
----------------
sdesmalen wrote:
> ctetreau wrote:
> > Out of curiosity, what is the eventual plan for this function? Does it go away, or will it just assert if this is a scalable vector?
> The eventual plan is for this function to go away, so we just have a single getElementCount interface, although this hasn't really been discussed yet.
> We could also end up renaming it to `getFixedVectorNumElements` for convenience, at which point it always asserts if it is scalable.
ok, thanks.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98856/new/

https://reviews.llvm.org/D98856



More information about the cfe-commits mailing list