[PATCH] D98856: Always emit error for wrong interfaces to scalable vectors, unless cmdline flag is passed.

Sander de Smalen via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Mar 24 09:17:07 PDT 2021


sdesmalen added inline comments.


================
Comment at: llvm/lib/CodeGen/ValueTypes.cpp:17
 
+unsigned EVT::getVectorNumElements() const {
+  auto Error = []() {
----------------
ctetreau wrote:
> Out of curiosity, what is the eventual plan for this function? Does it go away, or will it just assert if this is a scalable vector?
The eventual plan is for this function to go away, so we just have a single getElementCount interface, although this hasn't really been discussed yet.
We could also end up renaming it to `getFixedVectorNumElements` for convenience, at which point it always asserts if it is scalable.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98856/new/

https://reviews.llvm.org/D98856



More information about the cfe-commits mailing list