[PATCH] D96203: [clang][patch] Modify sanitizer options names: renaming blacklist to blocklist
Melanie Blower via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Feb 12 06:40:40 PST 2021
mibintc added a comment.
In D96203#2559426 <https://reviews.llvm.org/D96203#2559426>, @vitalybuka wrote:
>>> FWIW I would prefer denylist as well. (Also uses of whitelist should be allowlist, but also incremental :)
>
> I feel like existing and proposed value do match the meaning of this list.
> maybe ignorelist, skiplist (can be confused with data structure?), or just asan_no_sanitize.txt or even no_asan.txt
Would you use ignorelist (skiplist) in the option name as well as the filename? Can you recommend a name for the antonym as well (i.e. replacement for whitelist)
>> I can change D82244 <https://reviews.llvm.org/D82244> used blocklist to denylist . If there is no need for compatibility, I'll just replace the strings. If there is need for compatibility, I can make blocklist an alias.
>
> I don't think we need compatibility for D82244 <https://reviews.llvm.org/D82244>. If we change clang, we can update D82244 <https://reviews.llvm.org/D82244> to the same for consistency.
Yes I agree.
================
Comment at: clang/unittests/Driver/SanitizerArgsTest.cpp:134-136
Contains(StrEq("-fxray-always-instrument=" + XRayWhitelist)));
EXPECT_THAT(Command.getArguments(),
+ Contains(StrEq("-fxray-never-instrument=" + XRayBlocklist)));
----------------
vitalybuka wrote:
> always/never?
Can you say a few more works here? You mean use always as replacement for white, and never as replacement for black?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D96203/new/
https://reviews.llvm.org/D96203
More information about the cfe-commits
mailing list