[PATCH] D94884: [Clang][OpenMP] Include header for CUDA builtin vars into OpenMP wrapper header
Shilei Tian via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Mon Jan 18 19:31:38 PST 2021
tianshilei1992 marked 3 inline comments as done.
tianshilei1992 added inline comments.
================
Comment at: clang/lib/Headers/__clang_cuda_builtin_vars.h:52
+ property(get = __fetch_builtin_##NAME##_##FIELD)) unsigned int FIELD;
+#endif
----------------
jdoerfert wrote:
> Why do we need these __fetch_builtins (for C). They have a different name than in the C++ variant anyway. In C we could just not define the __fetch stuff but only the Field. So `gridDim.x` will work fine.
`__declspec(property)` doesn't support C so that code were removed.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D94884/new/
https://reviews.llvm.org/D94884
More information about the cfe-commits
mailing list