[PATCH] D93846: [clang-format] PR16518 Add flag to suppress empty line insertion before access modifier
Björn Schäpers via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed Jan 13 11:53:39 PST 2021
HazardyKnusperkeks added a comment.
Apart from that last naming issue looks good to me.
================
Comment at: clang/lib/Format/Format.cpp:235
+ IO.enumCase(Value, "Never", FormatStyle::ELBAMS_Never);
+ IO.enumCase(Value, "DontModify", FormatStyle::ELBAMS_DontModify);
+ IO.enumCase(Value, "LogicalBlock", FormatStyle::ELBAMS_LogicalBlock);
----------------
MyDeveloperDay wrote:
> Other places use `Leave` I assume that means the same as DontModify?
If that's the case, we should stick with it. Although I personally find DontModify better.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D93846/new/
https://reviews.llvm.org/D93846
More information about the cfe-commits
mailing list