[PATCH] D89031: [SVE] Add support to vectorize_width loop pragma for scalable vectors
Sjoerd Meijer via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Wed Nov 25 09:19:37 PST 2020
SjoerdMeijer added a comment.
Thanks @david-arm for posting this proposal to the cfe list.
My confusion has been cleared up. The (new) proposal is to have:
1. vectorize_width(X) where X is an integer.
2. vectorize_width(X, fixed|scalable)
3. vectorize_width(fixed|scalable)
And with that 3rd option I agree that this allows us to express everything we want, and this patch needs adapting to this new proposal (just stating the obvious for clarity/completeness)
If scalable is used on a target that doesn't support this, a warning and falling back to fixed seems like the right thing to do.
I did have concerns about this, similarly like @fhahn:
> Hm, I am just a bit worried that it might be a bit confusing to users that do not know what scalable vectors are (it is obvious when knowing all about SVE, but I would assume most people don't necessarily know what this means). I guess that is not the biggest deal, as long vectorize_width(X, scalable) works for every target.
But since the new scalable option is opt-in, people don't need know about this if they don't want/need to, this should (hopefully) not be the case.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D89031/new/
https://reviews.llvm.org/D89031
More information about the cfe-commits
mailing list