[PATCH] D89849: Add option 'exceptions' to pragma clang fp

Melanie Blower via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Oct 21 14:16:45 PDT 2020


mibintc added inline comments.


================
Comment at: clang/lib/Parse/ParsePragma.cpp:3041
+  if (AnnotValue->ExceptionsValue)
+    Actions.setExceptionMode(Tok.getLocation(), *AnnotValue->ExceptionsValue);
   ConsumeAnnotationToken();
----------------
sepavloff wrote:
> mibintc wrote:
> > Did you consider adding ActOnPragmaFPExceptions? 
> The existing method `setExceptionMode` does everything that we need. Do you think it should be renamed to `ActOnPragmaFPExceptions`? Are there any advantages for this?
I think it's easier to understand if it's written to parallel the other 2 fp pragmas that have similar semantics (contract and reassociate). 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D89849/new/

https://reviews.llvm.org/D89849



More information about the cfe-commits mailing list