[PATCH] D89429: clang/Basic: Replace SourceManager::getMemoryBufferForFile, NFC
Jonas Devlieghere via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Fri Oct 16 12:45:37 PDT 2020
JDevlieghere added inline comments.
================
Comment at: clang/lib/Basic/SourceManager.cpp:705
+llvm::Optional<llvm::MemoryBufferRef>
+SourceManager::getMemoryBufferForFileOrNone(const FileEntry *File) {
const SrcMgr::ContentCache *IR = getOrCreateContentCache(File);
----------------
Would it make sense to rename this to the slightly less verbose `getMemoryBufferOrNone` now that it takes just the File as an argument? Or maybe even `getBufferOrNone` like the method in `ContentCache`.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D89429/new/
https://reviews.llvm.org/D89429
More information about the cfe-commits
mailing list