[PATCH] D82736: [clangd] Rename FS.view(None) to FS.viewWithDefaultCWD()
Arthur O'Dwyer via Phabricator via cfe-commits
cfe-commits at lists.llvm.org
Sun Jun 28 22:59:42 PDT 2020
Quuxplusone created this revision.
Quuxplusone added reviewers: sammccall, kadircet, dblaikie.
Herald added subscribers: cfe-commits, usaxena95, arphaman, jkorous, MaskRay, ilya-biryukov.
Herald added a project: clang.
Fixes an instance of `-Woverloaded-virtual` on GCC.
Clarifies the purpose of this particular function.
Frees up a register that was being used for this pointless parameter of type `llvm::NoneType`.
Also eliminate `virtual` from `view(PathRef)` because it is not intended to be overridden.
(This is how I propose to address the underlying issue that led to D82617 <https://reviews.llvm.org/D82617>, instead of D82617 <https://reviews.llvm.org/D82617>. Of course the final call is Kadir's-or-Sam's-or-ultimately-certainly-not-mine.)
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D82736
Files:
clang-tools-extra/clangd/ClangdServer.cpp
clang-tools-extra/clangd/Preamble.cpp
clang-tools-extra/clangd/SourceCode.cpp
clang-tools-extra/clangd/index/Background.cpp
clang-tools-extra/clangd/support/ThreadsafeFS.cpp
clang-tools-extra/clangd/support/ThreadsafeFS.h
clang-tools-extra/clangd/tool/ClangdMain.cpp
clang-tools-extra/clangd/unittests/ClangdTests.cpp
clang-tools-extra/clangd/unittests/HeaderSourceSwitchTests.cpp
clang-tools-extra/clangd/unittests/TestFS.h
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D82736.273996.patch
Type: text/x-patch
Size: 9728 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20200629/a39f3da5/attachment-0001.bin>
More information about the cfe-commits
mailing list